summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08f59a4f5378..57ef1b308168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ optdepends=(
"mingw-w64-srt: Secure, Reliable, Transport client/server network source/sink plugin"
"mingw-w64-curl: cURL network source and sink plugin"
"mingw-w64-bzip2: bz2 stream encoder and decoder plugin"
- "mingw-w64-libice: WebRTC audio/video network bin plugin"
+ "mingw-w64-libnice: WebRTC audio/video network bin plugin"
)
options=('!strip' '!buildflags' 'staticlibs')
conflicts=('mingw-w64-gst-plugins-bad')
@@ -40,11 +40,15 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/${_gitname}"
+ sed -i "s|link_args : \[noseh_link_args, '-lopencv_tracking'\],|link_args : \[noseh_link_args\],|" ext/opencv/meson.build
for _arch in $_architectures; do
mkdir -p "build-${_arch}" && pushd build-${_arch}
${_arch}-meson \
-D package-name="GStreamer (Arch Linux)" \
- -D package-origin="http://www.archlinux.org/" ..
+ -D package-origin="http://www.archlinux.org/" \
+ -D tests=disabled \
+ -D examples=disabled \
+ -D openexr=disabled ..
ninja
popd
done