summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6b52e94a9a3..0bfafc1c0c37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
pkgname=mingw-w64-hunspell
-pkgver=1.6.1
+pkgver=1.6.2
pkgrel=1
-pkgdesc="Spell checker and morphological analyzer library (mingw-w64)"
+pkgdesc="Spell checker and morphological analyzer library and program (mingw-w64)"
arch=(any)
-url="http://hunspell.github.io/"
+url="https://hunspell.github.io/"
license=("GPL" "LGPL" "MPL")
-makedepends=(mingw-w64-configure mingw-w64-readline)
-depends=(mingw-w64-gettext)
-optdepends=(mingw-w64-readline)
+makedepends=('mingw-w64-configure' 'mingw-w64-readline' 'mingw-w64-wine')
+depends=('mingw-w64-gettext' 'mingw-w64-ncurses' 'mingw-w64-readline')
options=(!strip !buildflags staticlibs !debug !emptydirs)
-source=("https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
-"01-relocate.patch")
-sha256sums=('30f593733c50b794016bb03d31fd2a2071e4610c6fa4708e33edad2335102c49'
+source=("hunspell-${pkgver}.tar.gz"::"https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
+ "01-relocate.patch")
+sha256sums=('3cd9ceb062fe5814f668e4f22b2fa6e3ba0b339b921739541ce180cac4d6f4c4'
'2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd hunspell-${pkgver}
+ cd "${srcdir}/hunspell-${pkgver}"
+
+ # Remove files created by patch
rm -rf src/tools/pathtools.cxx src/tools/pathtools.hxx
patch -Np1 -i ${srcdir}/01-relocate.patch
autoreconf -fi