summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0bfafc1c0c37..f02ca406f9f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Sun <adsun701@gmail.com>
pkgname=mingw-w64-hunspell
-pkgver=1.6.2
+pkgver=1.7.0
pkgrel=1
pkgdesc="Spell checker and morphological analyzer library and program (mingw-w64)"
arch=(any)
@@ -12,22 +12,22 @@ depends=('mingw-w64-gettext' 'mingw-w64-ncurses' 'mingw-w64-readline')
options=(!strip !buildflags staticlibs !debug !emptydirs)
source=("hunspell-${pkgver}.tar.gz"::"https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
"01-relocate.patch")
-sha256sums=('3cd9ceb062fe5814f668e4f22b2fa6e3ba0b339b921739541ce180cac4d6f4c4'
- '2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806')
+sha256sums=('bb27b86eb910a8285407cf3ca33b62643a02798cf2eef468c0a74f6c3ee6bc8a'
+ 'b3a978749ef723481286e6237944729b6965bc57eacc5407b5f7fedf7d6aa8a1')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/hunspell-${pkgver}"
-
+ cd "${srcdir}/hunspell-${pkgver}"
+
# Remove files created by patch
rm -rf src/tools/pathtools.cxx src/tools/pathtools.hxx
patch -Np1 -i ${srcdir}/01-relocate.patch
- autoreconf -fi
+ autoreconf -fiv
}
build() {
- cd hunspell-${pkgver}
+ cd "${srcdir}/hunspell-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \