summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 460a1a09811a..6763343f348d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-kconfig
pkgver=5.21.0
-pkgrel=1
+pkgrel=2
arch=(any)
pkgdesc="Configuration system (mingw-w64)"
license=("LGPL")
@@ -8,6 +8,7 @@ depends=(mingw-w64-qt5-base)
groups=(mingw-w64-kf5)
makedepends=(mingw-w64-cmake mingw-w64-extra-cmake-modules mingw-w64-qt5-tools)
options=(staticlibs !strip !buildflags)
+optdepends=(wine "kconfig: needed for EXE workaround symlink")
url="https://projects.kde.org/projects/frameworks/kconfig"
source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/kconfig-${pkgver}.tar.xz")
md5sums=('11782bb4555990deafa273f0288d2673')
@@ -33,7 +34,10 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ rm "$pkgdir/usr/${_arch}/bin/k"{read,write}"config5.exe"
+ rm "$pkgdir/usr/${_arch}/bin/kconfig_compiler_kf5.exe"
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ ln -s "/usr/bin/kconfig_compiler" "$pkgdir/usr/${_arch}/bin/kconfig_compiler_kf5.exe"
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
rm -rf "$pkgdir/usr/${_arch}/share"