summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ade217237b8e..44d9df67d807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jakob <grandchild@gmx.net>
pkgname=mingw-w64-libgit2
-pkgver=1.5.1
+pkgver=1.6.4
pkgrel=1
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
@@ -10,17 +10,14 @@ makedepends=(mingw-w64-cmake)
options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
-source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz"
- "0001-fix-uppercase-windows-h-include.patch")
-sha256sums=('7074f1e2697992b82402501182db254fe62d64877b12f6e4c64656516f4cde88'
- 'a7a87b9467ef4f0a4e2f68f75c4b3e30c6b681773c636192726e59500538cf7d')
+source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz")
+sha256sums=('d25866a4ee275a64f65be2d9a663680a5cf1ed87b7ee4c534997562c828e500d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/libgit2-${pkgver}"
- patch -p1 < "$srcdir/0001-fix-uppercase-windows-h-include.patch"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \