summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bce6c4c7d7e..0776b2f85b80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,26 @@
pkgname=mingw-w64-libpsl
_pkgname=libpsl
-pkgver=0.21.2
-pkgrel=3
+pkgver=0.21.5
+pkgrel=1
pkgdesc='Public Suffix List library (mingw-w64)'
url='https://github.com/rockdaboot/libpsl'
arch=(any)
license=('MIT')
depends=('mingw-w64-libidn2' 'mingw-w64-libunistring')
makedepends=('mingw-w64-meson' 'gtk-doc')
-source=(https://github.com/rockdaboot/libpsl/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz
- c47cf796.patch
- 3dfe19d4578c361f800738c9c974d9c405801209.patch)
-sha512sums=('f1df72220bf4391d4701007100b0df66c833a2cbcb7481c9d13f0b9e0cad3b66d2d15d4b976e5bad60d2ad1540355112fa1acb07aa925c241d2d7cd20681c71d'
- 'a9b82a88c51abe86f10e65104b86afd345d992389fdbc4a7a71df632e2a3a1eb24f831103325e0d65205d081b9f6402864100a8f9b9b173e09e86f9d505f3355'
- '4f307e6a0dbd119c46de2f36d2121156ca785138e3e158b29bbc075ca7f177027ae11ed3c677c6a56f235ee1b8784cc9ea82db7569465ec76bc8dd8d71191832')
+source=(https://github.com/rockdaboot/libpsl/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz)
+sha512sums=('c14d575cecc0f1693894dd79565b6b9220084ddfa43b908a1cefe16d147cdd5ec47796eb0c2135e2f829a951abaf39d8a371ab5c1352f57b36e610e25adf91f5')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i ${srcdir}/c47cf796.patch
-}
-
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p "build-${_arch}" && pushd build-${_arch}
${_arch}-meson \
+ -D strip=true \
-D docs=false \
- -D b_lto=false \
-D runtime=libidn2 ..
ninja
popd