summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e551fd64a9c9..e741f2a221a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: bubla <matej.tyc@gmail.com>
pkgname=mingw-w64-libtiff
pkgver=4.0.7
-pkgrel=2
+pkgrel=3
pkgdesc="Library for manipulation of TIFF images (mingw-w64)"
arch=(any)
url="http://www.remotesensing.org/libtiff"
@@ -9,11 +9,18 @@ license=("custom")
depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib mingw-w64-xz)
makedepends=(mingw-w64-configure)
options=(staticlibs !buildflags !strip)
-source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz")
-sha1sums=('2c1b64478e88f93522a42dd5271214a0e5eae648')
+source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz"
+"fix-hylafax.patch")
+sha1sums=('2c1b64478e88f93522a42dd5271214a0e5eae648'
+ '32166444112dc283ffa4ffdb56c81f246243434c')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/tiff-${pkgver}"
+ patch -Nbp1 -i ${srcdir}/fix-hylafax.patch
+}
+
build() {
export CFLAGS+=" -fno-strict-aliasing"
export CXXFLAGS+=" -fno-strict-aliasing"