summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 524fdf23eeed..e9f01334fc6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Contributor: bubla <matej.tyc@gmail.com>
pkgname=mingw-w64-libtiff
pkgver=4.0.8
-pkgrel=1
+pkgrel=2
pkgdesc="Library for manipulation of TIFF images (mingw-w64)"
arch=(any)
-url="http://www.remotesensing.org/libtiff"
+url="http://www.simplesystems.org/libtiff/"
license=("custom")
depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib mingw-w64-xz)
makedepends=(mingw-w64-configure)
options=(staticlibs !buildflags !strip)
-source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz")
-sha256sums=('59d7a5a8ccd92059913f246877db95a2918e6c04fb9d43fd74e5c3390dac2910')
+source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz"
+"CVE-2016-10095.patch")
+sha256sums=('59d7a5a8ccd92059913f246877db95a2918e6c04fb9d43fd74e5c3390dac2910'
+ '36063a31e9317c3745b5e03b210c948586ea469205b06d3dde2e1b2493f18d81')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd tiff-$pkgver
+ patch -p1 -i ../CVE-2016-10095.patch # Fix several security issues
+}
+
build() {
export CFLAGS+=" -fno-strict-aliasing"
export CXXFLAGS+=" -fno-strict-aliasing"