summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8162b3e2de3d..dbab28c0b27c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,35 @@
-# Maintainer: naelstrof <naelstrof@gmail.com>
+# Contributor: naelstrof <naelstrof@gmail.com>
pkgname=mingw-w64-libvorbis
-pkgver=1.3.4
-pkgrel=3
+pkgver=1.3.5
+pkgrel=1
pkgdesc="Vorbis codec library (mingw-w64)"
arch=(any)
url="http://xiph.org"
license=('custom')
depends=('mingw-w64-libogg' 'mingw-w64-crt')
-makedepends=('mingw-w64-gcc' 'mingw-w64-binutils' 'mingw-w64-pkg-config')
+makedepends=('mingw-w64-configure')
options=(!strip !buildflags staticlibs)
source=(http://downloads.xiph.org/releases/vorbis/libvorbis-${pkgver}.tar.gz)
-md5sums=('8851c593a52d1ef9c526d95174873852')
+md5sums=('7220e089f3be3412a2317d6fde9e3944')
+
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- unset LDFLAGS
- #-march=i686 optimizes too much, strip it out
+ cd "${srcdir}/libvorbis-${pkgver}"
for _arch in ${_architectures}; do
- mkdir -p "${srcdir}/libvorbis-${pkgver}-build-${_arch}"
- cd "${srcdir}/libvorbis-${pkgver}-build-${_arch}"
- CFLAGS=${CFLAGS/-march=$CARCH} "${srcdir}"/libvorbis-${pkgver}/configure --enable-static --enable-shared --prefix=/usr/${_arch} --host=${_arch}
- make
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure ..
+ make
+ popd
done
}
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}"/libvorbis-${pkgver}-build-${_arch}
- make DESTDIR="$pkgdir" install
- rm -r "$pkgdir"/usr/${_arch}/share/doc
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ cd "${srcdir}"/libvorbis-${pkgver}/build-${_arch}
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir"/usr/${_arch}/share/doc
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}