summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fa9b19f10a9..fa81c91ca70b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
pkgname=mingw-w64-libzip
-pkgver=0.11.1
-pkgrel=4
+pkgver=1.0.1
+pkgrel=1
pkgdesc="A C library for reading, creating, and modifying zip archives (mingw-w64)"
url="http://www.nih.at/libzip/index.html"
license=('BSD')
arch=(any)
depends=('mingw-w64-crt' 'mingw-w64-zlib')
-makedepends=('mingw-w64-configure')
+makedepends=('mingw-w64-cmake')
options=('staticlibs' '!buildflags' '!strip')
source=("http://www.nih.at/libzip/libzip-${pkgver}.tar.xz"
- 'fix-headers.patch')
-md5sums=('87d5ec3629f6ad2a4b01ad961e7f0c19'
- '249395bd3a426c4c4e993e9d4753e1dd')
-
+ 'libzip_cmake-fixes.patch')
+md5sums=('e2371fc6f04a46efdaf8cbf4118ffafd'
+ 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "$srcdir/libzip-${pkgver}"
- patch -p1 -i "$srcdir/fix-headers.patch"
- autoreconf -vfi
+ patch -p1 -i "$srcdir/libzip_cmake-fixes.patch"
}
build() {
cd "$srcdir/libzip-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure
+ ${_arch}-cmake ..
make
popd
done
@@ -36,6 +34,7 @@ package() {
for _arch in ${_architectures}; do
cd "$srcdir/libzip-${pkgver}/build-$_arch"
make DESTDIR="${pkgdir}" install
+ ln -s /usr/${_arch}/lib/libzip/include/zipconf.h "$pkgdir"/usr/${_arch}/include/zipconf.h
rm -r "$pkgdir"/usr/${_arch}/share/
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip --strip-all "$pkgdir"/usr/${_arch}/bin/*.exe