summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD438
1 files changed, 438 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc0b5dc301b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,438 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+# Contributor: jellysheep <max.mail@dameweb.de>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# All patches are managed at https://github.com/Martchus/qtbase
+
+# There are different variants of the package which can be selected by simply adjusting pkgname:
+# - mingw-w64-qt5-base or mingw-w64-qt5-base-opengl: using native OpenGL
+# - mingw-w64-qt5-base-angle: using ANGLE rather than native OpenGL
+# - mingw-w64-qt5-base-dynamic: allows choosing between ANGLE and native OpenGL dynamically at runtime
+# - mingw-w64-qt5-base-noopenql: no OpenGL support
+# The variants are conflicting (and hence can not be installed at the same time).
+# See also: http://doc.qt.io/qt-5/windows-requirements.html#dynamically-loading-graphics-drivers
+
+# The variants listed above only contain dynamic libraries. For building static libraries
+# just append '-static' to the package name, eg. mingw-w64-qt5-base-static or mingw-w64-qt5-base-angle-static.
+# The static variants rely on the corresponding dynamic variant for headers and tools.
+# I only tested the static variant using native OpenGL so far (mingw-w64-qt5-base-static).
+# Note that ANGLE will still be loaded as dynamic library in mingw-w64-qt5-base-dynamic-static.
+
+# By default CMake and qmake will link against the dynamic Qt libraries.
+
+# To use the static Qt libraries with CMake prepend the Qt module name with Static:
+# eg. find_package(Qt5Core) becomes find_package(StaticQt5Core)
+# To use a static module, add the corresponding imported target, eg.
+# target_link_libraries(target ... StaticQt5::Core)
+# and using
+# This approach allows installing dynamic and static Qt in the same prefix
+# and using both variants in the same CMake project.
+
+# To use a static plugin, add the corresponding imported target, eg.
+# target_link_libraries(target ... StaticQt5::QWindowsIntegrationPlugin)
+# Automatically importing static plugins is currently not possible, though. Hence it is required to use Q_IMPORT_PLUGIN, eg.
+# #include<QtPlugin>
+# Q_IMPORT_PLUGIN(QWindowsIntegrationPlugin)
+
+# It is also possible to use static Qt libraries with CMake by setting the
+# variable USE_STATIC_QT_BY_DEFAULT: set(USE_STATIC_QT_BY_DEFAULT ON)
+# In this case the regular imported targets (eg. Qt5::Core) will be static.
+# This approach does *not* allow to use dynamic and static Qt in the same
+# CMake project.
+
+# To use the static Qt libraries with qmake add 'static' to the project config (either inside the *.pro file or as qmake argument):
+# CONFIG+=static
+
+# Further Qt modules (those not found in the base repository and hence not included in this package) include by default
+# static and dynamic libraries; if only one version is requried, just set NO_STATIC_LIBS or NO_SHARED_LIBS when building
+# the package, eg. by adding 'NO_STATIC_LIBS=1' to /etc/makepkg.conf.
+
+# By default, executables will not be removed because I find them useful when testing. To remove executables
+# set NO_EXECUTABLES (or NO_STATIC_EXECUTABLES to remove statically linked executables only) when building the package.
+# If Qt modules containing tools are built as static and as dynamic library only the dynamically linked tools will be present
+# in the package.
+
+# Qt packages can be built in the following order (for example):
+# qt5-base qt5-base-static qt5-declarative qt5-tools qt5-xmlpatterns qt5-script qt5-location qt5-multimedia qt5-sensors qt5-webchannel qt5-3d qt5-imageformats qt5-quickcontrols qt5-quickcontrols2 qt5-translations qt5-svg qt5-websockets qt5-winextras qt5-serialport qt5-canvas3d qt5-connectivity qt5-charts qt5-gamepad qt5-scxml qt5-datavis3s qt5-virtualkeyboard qt5-activeqt qt5-webkit
+
+# Helper functions for the split builds
+isDefault() {
+ [[ $pkgname = 'mingw-w64-qt5-base' ]] || [[ $pkgname = 'mingw-w64-qt5-base-static' ]]
+}
+isStatic() {
+ [ "${pkgname##*-}" = 'static' ]
+}
+isOpenGL() {
+ # Currently use native OpenGL by default
+ isDefault || \
+ [[ $pkgname = 'mingw-w64-qt5-base-opengl' ]] || [[ $pkgname = 'mingw-w64-qt5-base-opengl-static' ]]
+}
+isANGLE() {
+ [[ $pkgname = 'mingw-w64-qt5-base-angle' ]] || [[ $pkgname = 'mingw-w64-qt5-base-angle-static' ]] || \
+ [[ $pkgname = 'mingw-w64-qt5-base-dynamic' ]] || [[ $pkgname = 'mingw-w64-qt5-base-dynamic-static' ]]
+ # Treat dynamic version like ANGLE version, correct?
+}
+isDynamic() {
+ [[ $pkgname = 'mingw-w64-qt5-base-dynamic' ]] || [[ $pkgname = 'mingw-w64-qt5-base-dynamic-static' ]]
+}
+isNoOpenGL() {
+ [[ $pkgname = 'mingw-w64-qt5-base-noopengl' ]] || [[ $pkgname = 'mingw-w64-qt5-base-noopengl-static' ]]
+}
+
+pkgname=mingw-w64-qt5-base-nostatx
+pkgver=5.10.1
+pkgrel=1
+pkgdesc='A cross-platform application and UI framework (mingw-w64)'
+# The static variant doesn't contain any executables which need to be executed on the build machine
+isStatic && arch=('any') || arch=('i686' 'x86_64')
+url='https://www.qt.io/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-libjpeg-turbo' 'mingw-w64-sqlite'
+ 'mingw-w64-libpng' 'mingw-w64-openssl' 'mingw-w64-dbus' 'mingw-w64-harfbuzz'
+ 'mingw-w64-pcre2')
+groups=('mingw-w64-qt5')
+optdepends=('mingw-w64-postgresql: PostgreSQL support' 'mingw-w64-mariadb-connector-c: MySQL support')
+makedepends=('mingw-w64-gcc' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-pkg-config')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+_pkgfqn="qtbase-everywhere-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Add-profile-for-cross-compilation-with-mingw-w64.patch'
+ '0002-Ensure-GLdouble-is-defined-when-using-dynamic-OpenGL.patch'
+ '0003-Use-external-ANGLE-library.patch'
+ '0004-Fix-too-many-sections-assemler-error-in-OpenGL-facto.patch'
+ '0005-Make-sure-.pc-files-are-installed-correctly.patch'
+ '0006-Don-t-add-resource-files-to-LIBS-parameter.patch'
+ '0007-Prevent-debug-library-names-in-pkg-config-files.patch'
+ '0008-Fix-linking-against-shared-static-libpng.patch'
+ '0009-Fix-linking-against-static-D-Bus.patch'
+ '0010-Don-t-try-to-use-debug-version-of-D-Bus-library.patch'
+ '0011-Fix-linking-against-static-freetype2.patch'
+ '0012-Fix-linking-against-static-harfbuzz.patch'
+ '0013-Fix-linking-against-static-pcre.patch'
+ '0014-Fix-linking-against-shared-static-MariaDB.patch'
+ '0015-Fix-linking-against-shared-static-PostgreSQL.patch'
+ '0016-Rename-qtmain-to-qt5main.patch'
+ '0017-Build-dynamic-host-libraries.patch'
+ '0018-Enable-rpath-for-build-tools.patch'
+ '0019-Use-system-zlib-for-build-tools.patch'
+ '0020-Use-.dll.a-as-import-lib-extension.patch'
+ '0021-Merge-shared-and-static-library-trees.patch'
+ '0022-Pull-dependencies-of-static-libraries-in-CMake-modul.patch'
+ '0023-Allow-usage-of-static-version-with-CMake.patch'
+ '0024-Adjust-linker-flags-for-static-build-with-cmake-ming.patch'
+ '0025-Use-correct-pkg-config-static-flag.patch'
+ '0026-Fix-macro-invoking-moc-rcc-and-uic.patch'
+ '0027-Ignore-errors-about-missing-feature-static.patch'
+ '0028-Enable-and-fix-use-of-iconv.patch'
+ '0029-Ignore-failing-pkg-config-test.patch'
+ '0030-Prevent-qmake-from-messing-static-lib-dependencies.patch'
+ '0031-Hardcode-linker-flags-for-platform-plugins.patch'
+ '0032-Fix-linking-against-static-plugins-with-qmake.patch'
+ qt-no-statx.patch
+)
+sha256sums=('d8660e189caa5da5142d5894d328b61a4d3ee9750b76d61ad74e4eee8765a969'
+ '6b29d7a3751a506c15155425d6dc213e9f4654ee5b833007a0119bda6a050b28'
+ 'ca10438f4a2d309f496e85d7b974d9eeb88115e068e146ca511b9784db95b822'
+ '75bf0d8b155f95bad2dfbc5c046f88afd6a5f2233336a1f6d148583ba445fca6'
+ 'd70dcd1c44e751b0120f514af9db4ff20ebb0a327a22a371cf5e8d9453f66953'
+ 'cbad834340bc9e9261704034e9192bd0d7306f9ff02a99fd73fc348948c37ed9'
+ '3c7cd1839a6f0891b871c75824b8ebeb05e4e61884c342d6b6ab583f10819138'
+ 'c923da99871dac4fc58b8e70bd76c70fba0f421fc676a53bcb8c0187190ba737'
+ 'f9be656281652f72297f1e573f23298c22f4849857d92106096feb4b3fe9244f'
+ '5add111a9e521159e31ecef4d85ebef86285bbbe2adce5d8cec94fd22822731e'
+ '7d38e79bc6b2e5d74515291bf78c3a6168f8bc834f7f59bda2c013f65e45bd3e'
+ '9ab62cc8cd1cf68ee5e87e276d5a2f19c43b04a1c50c10341794924277cfcca5'
+ 'f1926bd51376a95ea1deee933dadd62166296e5780e24ce8312637c9d3eda27b'
+ '03f7a178af6b630f48da79c76e1239695d96137fd8394ba814e4bdf8c7e0a826'
+ 'dc3e0e3fe4ba979f74ff9dc343b235d32473edb18ca7f8afea3076f613564a95'
+ 'ef64b965a19e1e2848761829a6817dcb9f3ad616faa666f9e52736d810190c66'
+ '9e0c3848df586ec7decd9b7a6dab86a9e7e5cc7bf5ac06ff97d7d63e370bb05b'
+ '7dc90045a838f9ebcb7933d582abb3e8bba250644602e1019bf1a03e74cc3b09'
+ 'b5cc23a29e80ec8185da8ca0950ab8a2f12f4ef4b998c763334d352e68b53fc2'
+ '944cfdbfd9d13285aefb4305596950d2880cc1023b5ad241af08e3d6995daa69'
+ '5f7498a98912542c39b081c2df1930246df3bdb533c2e30204bf795cea8b885f'
+ '0b8408d70a4544e43fd573e5b9ac751fb2732d3e4490f21e1737ac09ece25b62'
+ '08155a41f22c03741096145bf201d5503e38495c2f255f3c81ea658948258cd3'
+ '7b30d46f739dffa20a1964e09958a92af1749104fe7a88d7ea255aa54e553b25'
+ 'c92d6a124b7b0333175122555ef9f647817eb54563480cf3eaaf47decfd907c3'
+ '0818c4d59aabb898fed8f313e21085cc8fc576d3f4975383eb73ba3f758c302e'
+ 'ce5d416a3404199072062063d8038084c23bbfe8aa45ed3340c4afb4dfa461e4'
+ '8d1e93bea1cdcdf1b965f4c061975668334cef6a65130f1b4b528f2b6952a602'
+ '298ffdcd378e2b07fe8e978cfb5faac29c117a5f79288273545a6938b905f33a'
+ '7514edba8ecd28b27715650bbafa8649492b68efba1df9c9fa70f06a924fea14'
+ '7c232c385303b447e17270b946d333b56274312b08b4e76439a5f77cb77aa909'
+ 'acfdf70ae8738a0373bbd93e42048d1c699f666dd72933ad3c09b09620fb0715'
+ 'c3df40da9b2494e59aae786a26ba93d88128b69971d10a64cb6d610045a101f8'
+ 'fb4c2d464cd7c3fbd1bf488cf694dcfdc6cb515a8d7ddb9b41d9b6bef5da3be2')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+isStatic && depends+=(${pkgname%-static})
+if isANGLE; then
+ if isDynamic; then
+ makedepends+=('mingw-w64-angleproject')
+ optdepends+=('mingw-w64-angleproject: use ANGLE instead of native OpenGL')
+ else
+ depends+=('mingw-w64-angleproject')
+ fi
+fi
+if ! isDefault; then
+ if isStatic; then
+ provides+=('mingw-w64-qt5-base-static')
+ conflicts+=('mingw-w64-qt5-base-static' 'mingw-w64-qt5-base-angle-static' 'mingw-w64-qt5-base-noopengl-static'
+ 'mingw-w64-qt5-base-dynamic-static' 'mingw-w64-qt5-base-openql-static')
+ else
+ provides+=('mingw-w64-qt5-base')
+ conflicts+=('mingw-w64-qt5-base' 'mingw-w64-qt5-base-angle' 'mingw-w64-qt5-base-noopengl'
+ 'mingw-w64-qt5-base-dynamic' 'mingw-w64-qt5-base-openql')
+ fi
+fi
+
+patch() {
+ local input_found=
+ local patch_file=
+ for arg in $@; do
+ if [[ $input_found ]]; then
+ patch_file="$arg"
+ break
+ fi
+ [[ $arg == -i ]] && input_found=1
+ done
+ msg2 "Applying patch $patch_file"
+ /usr/bin/patch $@
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # Apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
+
+ # Make sure the Qt5 build system uses our external ANGLE library
+ rm -rf src/3rdparty/angle include/QtANGLE/{EGL,GLES2,GLES3,KHR}
+
+ # As well as our external PCRE library and zlib
+ rm -rf src/3rdparty/{pcre,zlib}
+}
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # Do not set any flags here, flags are configured via mkspec
+ # Setting flags here is not appropriate as it does not allow to
+ # distinguish between flags for native compiler and cross compiler
+ unset CFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset PKG_CONFIG_PATH
+
+ for _arch in ${_architectures}; do
+ # To prevent conflicts with the mingw-w64-qt4 package we have
+ # to put tools in a dedicated folder
+
+ # The last device option allows using ccache despite the use of
+ # pre-compile header
+ # (sloppiness must be set to pch_defines,time_macros in ccache config)
+
+ local qt_configure_args="\
+ -xplatform mingw-w64-g++ \
+ -optimized-qmake \
+ -verbose \
+ -opensource \
+ -confirm-license \
+ -force-pkg-config \
+ -force-debug-info \
+ -system-zlib \
+ -system-libpng \
+ -system-libjpeg \
+ -system-sqlite \
+ -system-freetype \
+ -system-harfbuzz \
+ -system-pcre \
+ -no-fontconfig \
+ -sql-mysql \
+ -sql-psql \
+ -sql-sqlite \
+ -dbus-linked \
+ -no-glib \
+ -no-icu \
+ -iconv \
+ -nomake examples \
+ -make tools \
+ -hostprefix /usr/${_arch} \
+ -hostdatadir /usr/${_arch}/lib/qt \
+ -hostbindir /usr/${_arch}/lib/qt/bin \
+ -prefix /usr/${_arch} \
+ -bindir /usr/${_arch}/bin \
+ -archdatadir /usr/${_arch}/lib/qt \
+ -datadir /usr/${_arch}/share/qt \
+ -docdir /usr/${_arch}/share/doc/qt \
+ -examplesdir /usr/${_arch}/share/qt/examples \
+ -headerdir /usr/${_arch}/include/qt \
+ -libdir /usr/${_arch}/lib \
+ -plugindir /usr/${_arch}/lib/qt/plugins \
+ -sysconfdir /usr/${_arch}/etc \
+ -translationdir /usr/${_arch}/share/qt/translations \
+ -device-option CROSS_COMPILE=${_arch}- \
+ -device-option CROSS_COMPILE_PREFIX=/usr/${_arch} \
+ -device-option CROSS_COMPILE_CFLAGS=-fpch-preprocess"
+
+ # Fix include directory of freetype2 and dbus
+ qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I freetype2 dbus-1)"
+
+ # Enable debug build if MINGW_W64_QT_DEBUG_BUILD is set (in /etc/makepkg.config)
+ [[ $MINGW_W64_QT_DEBUG_BUILD ]] \
+ && qt_configure_args+=' -debug-and-release' \
+ || qt_configure_args+=' -release'
+
+ # Configure usage of ANGLE/OpenGL
+ if isOpenGL; then
+ msg2 'Using native OpenGL backend'
+ qt_configure_args+=' -opengl desktop'
+ elif isNoOpenGL; then
+ msg2 'Building without OpenGL support'
+ qt_configure_args+=' -no-opengl'
+ elif isANGLE; then
+ if isDynamic; then
+ msg2 'Using dynamic OpenGL backend'
+ qt_configure_args+=' -opengl dynamic'
+ else
+ msg2 'Using ANGLE as OpenGL backend'
+ qt_configure_args+=' -angle'
+ fi
+ # GL_GLEXT_PROTOTYPES must be defined to enable declarations of GLES functions
+ qt_configure_args+=' -DGL_GLEXT_PROTOTYPES'
+ fi
+
+ # Fix MariaDB
+ qt_configure_args+=" -I/usr/${_arch}/include/mariadb"
+
+ msg2 'Configure and build qmake'
+ mkdir -p ../build-${_arch} && pushd ../build-${_arch}
+ if isStatic; then
+ export OPENSSL_LIBS="/usr/${_arch}/lib/libssl.a /usr/${_arch}/lib/libcrypto.a -lws2_32 -lgdi32 -lcrypt32"
+ ../${_pkgfqn}/configure \
+ $qt_configure_args \
+ -static \
+ -openssl-linked
+ msg2 'Build static Qt libraries'
+ make
+ else
+ # The LD_LIBRARY_PATH override is needed because libQt5Bootstrap* are shared
+ # libraries which various compiled tools (like moc) use. As the libQt5Bootstrap*
+ # libraries aren't installed at this point yet, we have to workaround this
+ ../${_pkgfqn}/configure \
+ $qt_configure_args \
+ -shared \
+ -openssl-runtime \
+ -device-option 'CROSS_COMPILE_CUSTOM_CONFIG=actually_a_shared_build'
+ msg2 'Build shared Qt libraries'
+ LD_LIBRARY_PATH="$PWD/lib" LDFLAGS="-L$PWD/lib" make
+ fi
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/${_pkgfqn}"
+ make install -C ../build-${_arch} INSTALL_ROOT="${pkgdir}"
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ pushd "$srcdir/build-${_arch}/lib"
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ pushd "$srcdir/build-${_arch}/plugins"
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+
+ if isStatic; then
+ # The static release contains only the static libs itself but relies on the
+ # shared release for Qt5Bootstrap library and tools (qmake, uic, ...)
+
+ # Drop Qt5Bootstrap and libraries which are only provided as static lib
+ # and are hence already present in shared build (such as Qt5OpenGLExtensions)
+ rm -f \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}qt5main* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5AccessibilitySupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5DeviceDiscoverySupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5EdidSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5EventDispatcherSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5FbSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5FontDatabaseSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5PlatformCompositorSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5ThemeSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5OpenGLExtensions* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5PlatformSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"libQt5Bootstrap* \
+
+ # Also ensure config files don't conflict with shared version
+ pushd "${pkgdir}/usr/${_arch}/lib/cmake"
+ for cmake_dir in $(find . ! -path . -type d ! -name 'Static*'); do
+ mkdir -p "./Static${cmake_dir:2}";
+ mv "${cmake_dir}/"* "./Static${cmake_dir:2}";
+ rm -r "${cmake_dir}"
+ done
+ rm -r "./StaticQt5OpenGLExtensions"
+ popd
+ rm "${pkgdir}/usr/${_arch}/lib/pkgconfig/StaticQt5OpenGLExtensions.pc"
+
+ # Create links to static plugins in lib directory
+ pushd "${pkgdir}/usr/${_arch}/lib/" && ln -s "./qt/plugins/"*/*.a . && popd
+
+ # Keep a couple pri files not found in base
+ mv "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/modules/qt_plugin_"*.pri "${pkgdir}/usr/${_arch}"
+
+ # Delete duplicate files that are in the base package
+ rm -fR "${pkgdir}/usr/${_arch}/"{include,share}
+ rm -fR "${pkgdir}/usr/${_arch}/lib/"{qt/bin,qt/mkspecs}
+
+ # Move pri files back
+ mkdir -p "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/modules"
+ mv "${pkgdir}/usr/${_arch}/"*.pri "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/modules"
+
+ else # Shared release
+ # The .dll's are installed in both bindir and libdir, one copy of the .dll's is sufficient
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+
+ # The Qt5OpenGLExtensions module is only available as static library and hence part of the
+ # shared build
+
+ # Create symlinks for tools
+ mkdir -p "${pkgdir}/usr/bin"
+ for tool in qmake moc rcc uic qdbuscpp2xml qdbusxml2cpp qdoc syncqt.pl; do
+ ln -s "../${_arch}/lib/qt/bin/${tool}" "${pkgdir}/usr/bin/${_arch}-${tool}-qt5"
+ done
+ fi
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Remove doc
+ rm -rf "${pkgdir}/usr/${_arch}/share/doc"
+
+ # Strip the binaries
+ if ! isStatic; then
+ strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*[!.pl]
+ strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/libQt5Bootstrap"{,DBus}.so.${pkgver}
+ fi
+
+ # Applications might be useful as well; keeping them by default will not hurt anybody I suppose
+ if isStatic || [[ $NO_EXECUTABLES ]]; then
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \;
+ else
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
+ fi
+ # No use for these files though
+ find "${pkgdir}/usr/${_arch}" \( -name "*.bat" -o -name "*.def" -o -name "*.exp" \) -exec rm {} \;
+ # Strip binaries
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ done
+}