summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 526ce0953b84..a372ff0d00e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtgamepad
pkgname=mingw-w64-qt5-gamepad-static
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Adds support for getting events from gamepad devices (mingw-w64)"
@@ -17,18 +17,31 @@ depends=('mingw-w64-qt5-base-static' 'mingw-w64-sdl2')
optdepends=('mingw-w64-qt5-declarative-static: QML bindings')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-declarative-static')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=6b7a6303439f83147680723f4d8142d676cdb928
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('c77611f7898326d69176ad67a9b886f617cdedc368ec29f223d63537d25b075c')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"