summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82ad308c4c05..7f2483146cf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,37 +4,44 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qtlocation
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
# Skip building mapboxgl as it increases compile time significantly and
# likely not a lot of people actually using it; if you need it, just remove the
# following line:
-_mapboxcfg='QT.global.disabled_features+=geoservices_mapboxgl'
+_additional_qmake_args+='QT.global.disabled_features+=geoservices_mapboxgl'
_qt_module=qtlocation
pkgname=mingw-w64-qt5-location
-pkgver=5.14.0
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc='Provides access to position, satellite and area monitoring classes (mingw-w64)'
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Ensure-static-3rdparty-libs-are-linked-correctly.patch')
-sha256sums=('87906fd100dd93ed495a4db2c435dcfab073d399ea11d5e18727cc782fac4cd1'
- 'aa8551a7c6721ac98ebe2b3231cdf1d9d78fc0181409a31c9dd1d038afca50f6')
+sha256sums=('a0dd1712a5b7a0425b57d17318294b6f7e968c4b81d52048696d029b04d2f12f'
+ '5180fad65717eca47134e8019ada8f8f5e755df59c854568af35d0d5395d11b0')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -54,7 +61,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_mapboxcfg}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done