summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1075650a353..1a82417a4531 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,31 +12,40 @@
_qt_module=qtmultimedia
pkgname=mingw-w64-qt5-multimedia-static
-pkgver=5.15.1
+pkgver=5.15.13
pkgrel=1
arch=('any')
pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
depends=('mingw-w64-qt5-base-static' 'mingw-w64-qt5-declarative-static')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=7514352532f41d9f0f8b8d722e360b1854442731
+_basever=${pkgver%%+*}
+pkgver+=+kde+r2
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Recorder-includes-to-prevent-conflict-with-vsnprintf.patch'
'0002-Fix-build-with-ANGLE.patch'
'0003-Workaround-multiple-definition-errors-with-amstrmid-.patch')
-sha256sums=('ed6e75bec9c98559c0fbc91ff746185b1e1845139b2c7a5a843e1e8880697d99'
- '98d1157f57558204355b94b2f1fba7cbd9bd9bb561a5d66a0a48ffaab2894569'
- '8e189a64fd15bf2267cb58f3d3c23d0d2ad9eb8c5f07723546d5a6620c5915c3'
- '63860dba39d8c30dad59c0d9b4fc17e4da6e1e212e41520dbb8912e034974a40')
+sha256sums=('eef7a053fc4d4e33bdd1ae7dd0a2db32f755eacbf2e4a144246d33c3e02a0ab5'
+ '36bbaf9842fb930b4f17ae7ad2349b5dc9216492caeb7292f54d8fd7c0d66399'
+ 'b733514a287d915d74ddbbb901b2fae1a0c169becbadaf9bb63738392e383064'
+ '5ba3a72643af5e16b9f51ac9e5317d2f7e41dcb177f2201ac38ef0d0cd9a66e5')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
@@ -54,7 +63,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make
+ make -j$(nproc)
popd
done
done
@@ -67,7 +76,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then