summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa79bb293f71..1af273130411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-quick3d
-_qtver=6.1.0
+_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -12,13 +12,13 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='Qt module and API for defining 3D content in Qt Quick (mingw-w64)'
depends=('mingw-w64-qt6-declarative')
-makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'mingw-w64-assimp'
+makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader'
'mingw-w64-qt6-shadertools' 'qt6-quick3d' 'qt6-shadertools' 'ninja')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtquick3d-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('ead155359cf7fb8b2c1a69d00847196c4011433a4839938cc5f87f65a9d5d268')
+sha256sums=('94b45ae9d08495d701cfb586f1f85b12a1a10f8c29865de0d427a2366ae4507c')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -26,7 +26,8 @@ build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
- -DFEATURE_pkg_config=ON
+ -DFEATURE_pkg_config=ON \
+ -DFEATURE_quick3d_assimp=OFF
cmake --build build-$_arch
done
}