summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b96be082a5b7..4f9b7d19cb3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-scxml-static
-_qtver=6.5.1
+_qtver=6.5.2
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -18,7 +18,7 @@ options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtscxml-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('1c3ea3c8bb52c30e06ff113b4deaeb30d664d592afba650f0c1910b30a002477')
+sha256sums=('a830f2ec750913a70f854e487b1b44d1ec3a48eb21253f414a1990f8cf4dbdcb')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -27,6 +27,7 @@ build() {
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
-DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DFEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
cmake --build build-$_arch