summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c39438f62715..d07323f2364f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,18 @@
_reponame=qtutilities
pkgname=mingw-w64-qtutilities
_name=${pkgname#mingw-w64-}
-pkgver=6.0.6
+pkgver=6.1.0
pkgrel=1
arch=('any')
pkgdesc='Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models (mingw-w64)'
license=('GPL')
depends=('mingw-w64-crt' 'mingw-w64-qt5-base' 'mingw-w64-c++utilities')
optdepends=("$_name-doc: API documentation")
+checkdepends=('mingw-w64-wine')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('6e853502cc3a636d82e64f23e96050f8357f2937bca35ef3359c2ec75e8fedf3')
+sha256sums=('e060b4131e3193a7d72e6b4f4c70a19fddb3033c9e193dd87bc3381b265305bc')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
@@ -60,6 +61,19 @@ build() {
done
}
+check() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+
+ for _arch in "${_architectures[@]}"; do
+ for _cfg in "${_configurations[@]}"; do
+ msg2 "${_arch}-${_cfg}"
+ pushd "build-${_arch}-${_cfg}"
+ make WINEPATH="/usr/${_arch}/bin" WINEDEBUG=-all QT_QPA_PLATFORM=offscreen check || test "$_cfg" = static
+ popd
+ done
+ done
+}
+
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"