summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 560798cfaf07..a2523bff3577 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-rtmpdump
-pkgver=20140918
+pkgver=2.4.r96.fa8646d
pkgrel=1
pkgdesc="Tool to download rtmp streams (mingw-w64)"
arch=('any')
@@ -9,10 +9,20 @@ license=('GPL2' 'LGPL2.1')
depends=('mingw-w64-crt' 'mingw-w64-openssl')
options=('!strip' '!buildflags' '!makeflags' 'staticlibs')
makedepends=('mingw-w64-gcc' 'git')
-source=(git://git.ffmpeg.org/rtmpdump#commit=a1900c3)
-md5sums=('SKIP')
+_commit='fa8646d'
+source=("git://git.ffmpeg.org/rtmpdump#commit=${_commit}")
+sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd rtmpdump
+
+ _ver_name='2.4'
+ _ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
+
+ echo "${_ver_name}.r$(git rev-list --count ${_ver_commit}..HEAD).${_commit}"
+}
+
build() {
for _arch in ${_architectures}; do
cp -r ${srcdir}/rtmpdump ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
@@ -34,3 +44,4 @@ package() {
rm -r ${pkgdir}/usr/${_arch}/{sbin,share}
done
}
+# vim: ts=2 sw=2 et: