summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b8068f792f6..1da71c14a7b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Moritz Maxeiner <moritz@ucworks.org>
pkgname=mingw-w64-seafile-shared
-pkgver=4.2.3
-pkgrel=2
+pkgver=4.3.0
+pkgrel=1
pkgdesc="Shared components of seafile: seafile-daemon, libseafile, libseafile python bindings (mingw-w64)."
arch=(any)
url="https://github.com/haiwen/seafile/"
@@ -14,17 +14,21 @@ depends=('mingw-w64-crt' 'mingw-w64-ccnet>=3.0' 'mingw-w64-curl')
options=('!strip' '!buildflags' 'staticlibs')
source=("seafile-${pkgver}.tar.gz::https://github.com/haiwen/seafile/archive/v${pkgver}.tar.gz"
"seafile-pull-1265.patch::https://patch-diff.githubusercontent.com/raw/haiwen/seafile/pull/1265.patch")
-sha256sums=('9f4ffd912312e7154cecb8451612674e32400b345bb50345cb257c3da8218f44'
+sha256sums=('1e4bdd6dc5e2903fafc410cf2596e98c3083c91b0f2d1371cdc1286fa0f6866e'
'50ef89aa3d4382af7ba45c9c95530ce8b3a9c355dd1c425c35a26651c62692bb')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "$srcdir/seafile-${pkgver}"
+ # Fix for reference to $pkgdir in package
+ sed -i 's/(DESTDIR)//g' lib/libseafile.pc.in
# Fix for 64-bit compilation
patch -p1 -i "$srcdir"/seafile-pull-1265.patch
- # Case fixes on includes
+ # Case fixes on includes and configure script
sed -i 's/<Rpc.h>/<rpc.h>/g' lib/utils.c
+ sed -i 's/<AccCtrl.h>/<accctrl.h>/g' daemon/set-perm.c
+ sed -i 's/<AclApi.h>/<aclapi.h>/g' daemon/set-perm.c
sed -i 's/-lRpcrt4/-lrpcrt4/g' configure.ac
}