summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b6325dddff6..996d0fdbcf83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
pkgname=mingw-w64-utf8cpp
-pkgver=3.1
+pkgver=4.0.4
pkgrel=1
pkgdesc="UTF-8 with C++ in a Portable Way (mingw-w64)"
-url='http://utfcpp.sourceforge.net'
+url="https://github.com/nemtrif/utfcpp"
arch=('any')
license=('Custom')
depends=()
makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
source=("https://github.com/nemtrif/utfcpp/archive/v${pkgver}.tar.gz")
-sha256sums=('ab531c3fd5d275150430bfaca01d7d15e017a188183be932322f2f651506b096')
+sha256sums=('7c8a403d0c575d52473c8644cd9eb46c6ba028d2549bc3e0cdc2d45f5cfd78a0')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -18,8 +18,7 @@ build() {
cd "utfcpp-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- # CYGWIN=1 to trick the build system to install the cmake config in lib/cmake/utf8cpp instead
- ${_arch}-cmake -DUTF8_TESTS=OFF -DCYGWIN=1 ..
+ ${_arch}-cmake -DUTF8_TESTS=OFF -DUTF8_SAMPLES=OFF ..
make
popd
done