summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 590164931609..1b4df9c9179f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,15 +15,18 @@ options=(staticlibs !strip !buildflags)
conflicts=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
provides=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
source=("https://github.com/wxWidgets/wxWidgets/releases/download/v${pkgver}/wxWidgets-${pkgver}.tar.bz2"
- "fix-narrowing.patch")
+ "fix-narrowing.patch"
+ "cpp17-minmax.patch")
sha1sums=('406ac736f61d88a3a866aa501e01e408a642c6e7'
- '8657efb04e2c7befb83c3c9e5981f99b8484babf')
+ '8657efb04e2c7befb83c3c9e5981f99b8484babf'
+ 'a427db2f11b4f69d6aaca5c840e7a9b43883f782')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/wxWidgets-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/fix-narrowing.patch"
+ patch --forward --strip=1 --input="${srcdir}/cpp17-minmax.patch"
}
build() {