summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a64e467e9054..dd19b4a3b102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
# Maintainer: Ivan Puntiy <ivan.puntiy-at-gmail>
# Contributor: Schala
-pkgname=mingw-w64-wxmsw
+pkgname=mingw-w64-wxmsw3.1
epoch=1
-pkgver=3.0.2
+pkgver=3.1.0
pkgrel=1
-pkgdesc="Win32 implementation of wxWidgets API for GUI (mingw-w64)"
+pkgdesc="Win32 implementation of wxWidgets API for GUI (development branch, mingw-w64)"
arch=(any)
url="http://wxwidgets.org"
license=("custom:wxWindows")
makedepends=(mingw-w64-gcc)
depends=(mingw-w64-crt mingw-w64-libpng mingw-w64-libjpeg-turbo mingw-w64-libtiff)
options=(staticlibs !strip !buildflags)
-conflicts=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
-provides=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
-replaces=(mingw-w64-wxmsw2.9)
-source=("http://downloads.sourceforge.net/wxwindows/wxWidgets-${pkgver}.tar.bz2")
-sha1sums=('6461eab4428c0a8b9e41781b8787510484dea800')
+source=("https://github.com/wxWidgets/wxWidgets/releases/download/v${pkgver}/wxWidgets-${pkgver}.tar.bz2")
+sha1sums=('2170839cfa9d9322e8ee8368b21a15a2497b4f11')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -88,8 +85,9 @@ package() {
find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
- ln -s "/usr/${_arch}/lib/wx/config/${_arch}-msw-unicode-${pkgver%.*}" "$pkgdir/usr/bin/${_arch}-wx-config"
- rm "$pkgdir/usr/${_arch}/bin/wxrc-3.0"
+ ln -s "/usr/${_arch}/lib/wx/config/${_arch}-msw-unicode-${pkgver%.*}" "$pkgdir/usr/bin/${_arch}-wx-config-3.1"
+ mv "$pkgdir/usr/${_arch}/bin/wx-config"{,-3.1}
+ rm "$pkgdir/usr/${_arch}/bin/wxrc-3.1"
rm -r "$pkgdir/usr/${_arch}/share"
done
}