summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1733d14869c6..9e3816466d61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=mininet
-pkgver=2.3.0b2
-pkgrel=1
+pkgver=2.3.0
+pkgrel=2
pkgdesc='Emulator for rapid prototyping of Software Defined Networks'
depends=('python' 'iproute2' 'net-tools' 'iputils' 'inetutils' 'iperf' 'ethtool'
'libcgroup' 'openvswitch' 'psmisc')
@@ -17,20 +17,25 @@ arch=('x86_64')
url='https://github.com/mininet/mininet'
license=('custom')
install=mininet.install
-source=("https://github.com/mininet/mininet/archive/$pkgver.tar.gz"
- 'git+https://github.com/mininet/openflow') # for UserSwitch
-sha256sums=('9c879d995ba01717c739d5baedb11a35754f34b629579c640e5d3c48f835424f'
- 'SKIP')
+source=("https://github.com/mininet/mininet/archive/refs/tags/$pkgver.tar.gz"
+ 'git+https://github.com/mininet/openflow' # for UserSwitch
+ 'fix-openflow-strlcpy.patch')
+sha256sums=('1b16ee53ddb9a34a3751a77517643bda2286fc31be123209e84884d0697107b0'
+ 'SKIP'
+ '0a85f8a5ce2dd900d4f874849b28301aa47d7b9d7b03ed405c973d917d98383a')
prepare () {
cd "$srcdir/openflow"
sed '/^include debian\/automake.mk/d' -i Makefile.am
# Patch controller to handle more than 16 switches
patch -Np1 -i "$srcdir/$pkgname-$pkgver/util/openflow-patches/controller.patch"
+ patch -Np1 -i "$srcdir/fix-openflow-strlcpy.patch"
cd "$srcdir/$pkgname-$pkgver"
- sed 's:PREFIX ?= /usr:PREFIX ?= "$(DESTDIR)"/usr:' -i Makefile
- sed '/^[[:space:]]*$(PYTHON) /d' -i Makefile
+ # shellcheck disable=SC2016
+ sed -i Makefile \
+ -e 's:PREFIX ?= /usr:PREFIX ?= "$(DESTDIR)"/usr:' \
+ -e '/^[[:space:]]*$(PYTHON) /d'
}
build () {
@@ -41,6 +46,7 @@ build () {
cd "$srcdir/$pkgname-$pkgver"
make mnexec man
+ python setup.py build
}
package () {
@@ -49,6 +55,6 @@ package () {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="${pkgdir}" install
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/mininet/LICENSE"
}