summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aaa48bebee91..706ecf93c372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mininet
pkgver=2.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="Process-based network emulator (stable branch)"
url="https://github.com/mininet/mininet/"
license=('custom')
@@ -11,12 +11,11 @@ depends=('bash' 'python2' 'python2-networkx' 'net-tools' 'iputils' 'iperf')
optdepends=('openvswitch' 'xorg-xhost')
makedepends=('help2man' 'python2-setuptools')
arch=('i686' 'x86_64')
-source=("git://github.com/mininet/mininet.git")
-md5sums=('SKIP')
+source=("https://github.com/mininet/mininet/archive/$pkgver.tar.gz")
+sha256sums=('e4c20a6ab4ddfe4d5cad06ba25742507967df67a845dbe2e90d627af7cd21705')
prepare () {
- cd "$srcdir/$pkgname"
- git checkout -b 2.2.1 2.2.1
+ cd "$srcdir/$pkgname-$pkgver"
grep python2 Makefile && return
grep -rIil '#!.*python' . | xargs -n1 sed -i 's:#!/usr/bin/env python:#!/usr/bin/env python2:g'
grep -rIil '#!.*python' . | xargs -n1 sed -i 's:#!/usr/bin/python:#!/usr/bin/python2:g'
@@ -28,10 +27,10 @@ prepare () {
}
build () {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
}
package () {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="${pkgdir}" install
}