summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6fc77ddd6a6..84a07b278c1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,27 @@ _target="mips-harvard-os161"
pkgname=${_target}-gdb
_pkgver=7.8+os161-2.1
pkgver=${_pkgver/os161-/os161_}
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Debugger modified for ${_target} arquitecture. This is part of toolset for the course os161 from Harvard."
arch=(i686 x86_64)
url="http://os161.eecs.harvard.edu/"
license=('GPL' 'LGPL')
groups=('mips-harvard-os161-toolchain')
-depends=('mips-harvard-os161-binutils>=2.24' 'gmp' 'mpfr' 'libmpc')
+depends=('mips-harvard-os161-binutils>=2.24' 'gmp' 'mpfr' 'libmpc' 'guile2.0')
makedepends=('flex' 'bison')
options=(staticlibs !libtool !emptydirs !strip zipman docs)
-source=(http://os161.eecs.harvard.edu/download/gdb-${_pkgver}.tar.gz)
-md5sums=('26295f3f67090e534e3d488a3edce5ae')
+source=(http://os161.eecs.harvard.edu/download/gdb-${_pkgver}.tar.gz
+gdb.patch)
+md5sums=('26295f3f67090e534e3d488a3edce5ae'
+'SKIP')
prepare() {
cd gdb-${_pkgver}
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+ patch -p1 -i ${srcdir}/gdb.patch
+
mkdir ${srcdir}/gdb-build
}
@@ -34,6 +38,7 @@ build() {
../gdb-${_pkgver}/configure --prefix=/usr \
--program-prefix=${_target}- \
--with-local-prefix=/usr/lib/${_target} \
+ --with-guile=guile-2.0 \
--target=${_target} --host=${CHOST} --build=${CHOST} \
--disable-nls --nfp \
--disable-shared --disable-threads \