summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0f0ddc70a06..7f986e88bb22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=mist
-pkgver=0.3.9
-_pkgver=0-3-9
+pkgver=0.4.0
+_pkgver=0-4-0
pkgrel=1
pkgdesc="Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser)."
arch=('i686' 'x86_64')
@@ -32,25 +32,34 @@ optdepends=(
url="https://github.com/ethereum/mist"
license=('GPL')
source=(
- "${pkgname}-${_pkgver}-ia32.zip::https://github.com/ethereum/$pkgname/releases/download/${pkgver}/Ethereum-Wallet-linux32-$_pkgver.zip"
- "${pkgname}-${_pkgver}-x64.zip::https://github.com/ethereum/$pkgname/releases/download/${pkgver}/Ethereum-Wallet-linux64-$_pkgver.zip"
+ "${pkgname}-${_pkgver}-32.zip::https://github.com/ethereum/$pkgname/releases/download/${pkgver}/Ethereum-Wallet-linux32-$_pkgver.zip"
+ "${pkgname}-${_pkgver}-64.zip::https://github.com/ethereum/$pkgname/releases/download/${pkgver}/Ethereum-Wallet-linux64-$_pkgver.zip"
+ "mist.desktop"
+ "icon.png"
)
sha256sums=(
- "1102622f862c9001e3ce36d27bd76b4a0b29c4a4c359a9acf62ccdc4f5b8821d"
- "9d0bb4ca4fb8f4d5acba3596ac4231b9d1661583e91a5c4f03789aaab73b2952"
+ "36d598840ddde5fe0b58fb0daa1abb1a4b1eac649c21a6b2f7a748a6ccbca8ed"
+ "72fb57f5f9ab23ac53549f557861e3041ea68f8b185467f87513d20f13eb764e"
+ "d044844dd8ef1fef2ced861e5a86bf0d9af1b06ade6965dab1f12dbc612da207"
+ "f9dfeddf9730ab693e3dc69d6dd0ad48525de1e40e1c8fb46ed081a3e7bd5f93"
)
package() {
- _arch="ia32"
+ _arch="32"
if [ "${CARCH}" = "x86_64" ]; then
- _arch="x64"
+ _arch="64"
fi
rm "${srcdir}/${pkgname}-${_pkgver}-${_arch}.zip"
msg2 'Installing Mist...'
install -d "${pkgdir}/usr/share/${pkgname}"
- cp -a "${srcdir}/Ethereum-Wallet-linux-${_arch}-${_pkgver}/." "${pkgdir}/usr/share/${pkgname}"
+ cp -a "${srcdir}/Ethereum-Wallet-linux${_arch}-${_pkgver}/." "${pkgdir}/usr/share/${pkgname}"
+ cp -a "${srcdir}/icon.png" "${pkgdir}/usr/share/${pkgname}"
+
+ install -d "${pkgdir}/usr/share/applications"
+ cp -a "${srcdir}/mist.desktop" "${pkgdir}/usr/share/applications"
+
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/${pkgname}/Ethereum-Wallet" "${pkgdir}/usr/bin/mist"