summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3876c899cb5..ba75ea1252fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,14 @@ pkgver=r425.d542dc1
pkgrel=1
arch=('any')
url="https://github.com/byt3bl33d3r/MITMf"
-license=('unknown')
+license=('GNU')
provides=('mitmf')
makedepends=('git')
-depends=('python2' 'libnetfilter_queue' 'libpcap' 'libjpeg-turbo' 'capstone' 'python2-pyinotify' 'python2-crypto' 'python2-pyasn1' 'python2-cryptography' 'python2-pillow' 'python2-netaddr' 'scapy' 'python2-dnslib' 'python2-twisted' 'python2-lxml' 'python2-pefile-git' 'python2-ipy' 'python2-user_agent' 'python2-pyopenssl' 'python2-service-identity' 'python2-configobj' 'python2-flask' 'python2-dnspython' 'python2-beautifulsoup4' 'python2-capstone' 'python2-magic' 'python2-msgpack' 'python2-requests' 'python2-pypcap' 'python2-chardet' 'python2-netfilterqueue-git')
-source=("${pkgname}::git+https://github.com/byt3bl33d3r/MITMf")
-sha256sums=('SKIP')
+depends=('python2' 'libnetfilter_queue' 'libpcap' 'libjpeg-turbo' 'capstone' 'python2-pyinotify' 'python2-crypto' 'python2-pyasn1' 'python2-cryptography' 'python2-pillow' 'python2-netaddr' 'scapy' 'python2-dnslib' 'python2-twisted' 'python2-lxml' 'python2-pefile-git' 'python2-ipy' 'python2-user-agents' 'python2-pyopenssl' 'python2-service-identity' 'python2-configobj' 'python2-flask' 'python2-dnspython' 'python2-beautifulsoup4' 'python2-capstone' 'python2-magic' 'python2-msgpack' 'python2-requests' 'python2-pypcap' 'python2-chardet' 'python2-netfilterqueue-git' 'python2-ua-parser')
+source=("${pkgname}::git+https://github.com/byt3bl33d3r/MITMf"
+ "chdir.patch")
+sha256sums=('SKIP'
+ 'fa44f049c26e3bf2f911def34d70c047679217ded4612eb2996c5444245c3939')
options=(!strip)
pkgver() {
@@ -26,6 +28,7 @@ prepare() {
cd "${srcdir}/${pkgname}"
git submodule init
git submodule update --recursive
+ patch -p0 < ../chdir.patch
}
package() {