summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91f64ba3ace4..7c50d6875566 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mjpg-streamer-git
epoch=1
-pkgver=r355.85f89a8
+pkgver=1.0.0.r1.g310b29f
pkgrel=1
pkgdesc="Stream mjpeg frames from a webcam via http"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -18,12 +18,11 @@ source=("git+https://github.com/jacksonliam/mjpg-streamer.git")
sha256sums=(SKIP)
export LDFLAGS="-Wl,-O1,--sort-common,--no-as-needed,-z,relro,-z,now"
-
export CFLAGS="-fcommon"
pkgver() {
cd "${pkgname/-git/}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {