summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c7013bf6b6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer mrAppleXZ <mr.applexz@gmail.com>
+
+pkgname=mkmod-git
+pkgrel=1
+pkgver=1.0.r0.g6b8bde2
+pkgdesc="A shell script to clone & build the Minecraft mod that uses the Gradle build system."
+arch=('any')
+url='https://github.com/PearXTeam/mkmod'
+license=('GPL3')
+makedepends=('git')
+optdepends=("gradle: in case of the gradlew file doesn't exist")
+source=("$pkgname::git+git://github.com/PearXTeam/mkmod.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -D -m755 "mkmod.sh" "${pkgdir}/usr/bin/mkmod"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/mkmod"
+} \ No newline at end of file