summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1ea29e1f1db..bc96ce132fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@ pkgname=mksh-static-git
_pkgname=mksh
_pkgver=R56
pkgver=56.r3154.3a4eaf6
-pkgrel=1
+pkgrel=2
pkgdesc='The MirBSD Korn Shell - an enhanced version of the public domain ksh (statically-linked development version)'
url='https://www.mirbsd.org/mksh.htm'
license=('custom')
arch=('i686' 'x86_64')
-depends=('glibc') # Make namcap happy.
+depends=('musl') # Make namcap happy.
makedepends=('git')
conflicts=('mksh' 'mksh-static' 'mksh-git')
install=mksh.install
@@ -32,7 +32,7 @@ check() {
build() {
cd "$srcdir/$_pkgname"
- LDSTATIC=-static sh Build.sh -r
+ CC='musl-gcc -static' sh Build.sh -r
}
package() {