summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 34 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7876bb370375..a018ffb630a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,63 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=mkxp-git
-pkgver=r745.794e86d
+pkgver=r822.9dc4291
pkgrel=1
pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP/VX/VX Ace (development version)"
arch=('i686' 'x86_64')
url="https://github.com/Ancurio/mkxp"
license=('GPL2')
-depends=('ruby' 'physfs-hg' 'sdl2-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
- 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++' 'fluidsynth-git')
-makedepends=('git' 'boost' 'cmake' 'mesa' 'vim')
+depends=('ruby2.6' 'physfs' 'sdl2_image' 'sdl2_ttf' 'pixman' 'openal' 'boost-libs'
+ 'libgl' 'libsigc++' 'fluidsynth' 'libmodplug' 'libvorbis' 'flac')
+makedepends=('git' 'boost' 'cmake' 'mesa' 'vim' 'ninja')
conflicts=('mkxp')
provides=('mkxp')
install=mkxp.install
-source=("git+$url.git")
-md5sums=('SKIP')
+source=("git+$url.git"
+ "git+https://github.com/Ancurio/SDL_sound.git")
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd mkxp
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
+ rm -rf build
+
cd mkxp
- # get the major and minor version of installed ruby, remove any strings (like beta, patchlevel)
- _rubyver=$(pacman -Q ruby | sed -r 's/^ruby //;s/\.[^\.]+-.+$//;s/[^0-9\.]//')
- # check for validity, for example rubinius-ruby provides ruby, but cannot be used (no library)
- [ -z $_rubyver ] && exit 1
+ # add our sdl_sound
+ sed -e 's/SDL2_INCLUDE_DIRS/SDL_SOUND_INCLUDE_DIRS} ${&/' \
+ -e 's/SDL2_LIBRARY_DIRS/SDL_SOUND_LIBRARY_DIRS} ${&/' \
+ -e 's/SDL_SOUND_LIBRARIES}/& -logg -lFLAC -lmodplug/' -i CMakeLists.txt
- cmake ./ -DMRIVERSION=$_rubyver -DWORKDIR_CURRENT=ON -DSHARED_FLUID=ON
- make
+ # hotfix for new openal soft
+ grep -q ALCdevice_struct src/eventthread.h && \
+ sed '/ALCdevice_struct/d;i #include <alc.h>' -i src/eventthread.h
}
-package() {
- cd mkxp
+build() {
+ cd SDL_sound
+ ./bootstrap
+ ./configure --enable-static --disable-shared --prefix="$srcdir" \
+ --disable-speex --disable-mikmod
+ make install
+ export PKG_CONFIG_PATH="$srcdir/lib/pkgconfig:/opt/ruby2.6/lib/pkgconfig"
+
+ cd ../mkxp
+
+ cmake -G Ninja -B ../build -DWORKDIR_CURRENT=ON -DSHARED_FLUID=ON \
+ -DMRIVERSION=2.6 # fixme: build with 2.7
+ cmake --build ../build
+}
+package() {
# install architecture dependent executeable
- install -Dm755 mkxp.bin.x* "$pkgdir"/usr/bin/mkxp
+ install -Dm755 build/mkxp.bin.x* "$pkgdir"/usr/bin/mkxp
# install documentation
+ cd mkxp
install -Dm644 README.md "$pkgdir"/usr/share/doc/mkxp/README.md
install -m644 mkxp.conf.sample "$pkgdir"/usr/share/doc/mkxp
}