summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 031eb09720a7..7876bb370375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=mkxp-git
-pkgver=r470.151a1f0
+pkgver=r745.794e86d
pkgrel=1
-pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP (development version)"
+pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP/VX/VX Ace (development version)"
arch=('i686' 'x86_64')
url="https://github.com/Ancurio/mkxp"
license=('GPL2')
-depends=('ruby' 'physfs-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
- 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++' 'fluidsynth')
+depends=('ruby' 'physfs-hg' 'sdl2-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
+ 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++' 'fluidsynth-git')
makedepends=('git' 'boost' 'cmake' 'mesa' 'vim')
conflicts=('mkxp')
provides=('mkxp')
-optdepends=('fluidsynth-git: reduced memory footprint for midi playback')
install=mkxp.install
source=("git+$url.git")
md5sums=('SKIP')
@@ -25,7 +24,12 @@ pkgver() {
build() {
cd mkxp
- cmake ./ -DMRIVERSION=2.1 -DWORKDIR_CURRENT=ON
+ # get the major and minor version of installed ruby, remove any strings (like beta, patchlevel)
+ _rubyver=$(pacman -Q ruby | sed -r 's/^ruby //;s/\.[^\.]+-.+$//;s/[^0-9\.]//')
+ # check for validity, for example rubinius-ruby provides ruby, but cannot be used (no library)
+ [ -z $_rubyver ] && exit 1
+
+ cmake ./ -DMRIVERSION=$_rubyver -DWORKDIR_CURRENT=ON -DSHARED_FLUID=ON
make
}