summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 28 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb78b64dcb34..b7c97302ca21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgbase=mlapack
pkgname=('mlapack')
pkgver=0.8.1
-pkgrel=2
-pkgdesc="MPACK - Multiple precision linear algebra package"
+pkgrel=3
+pkgdesc="Multiple precision linear algebra package (fork of MPLAPACK)"
arch=('x86_64' 'i686')
license=('Custom')
url=""
@@ -15,25 +15,42 @@ makedepends=( 'qd'
'gmp'
'mpfr'
'libmpc'
- 'libtool'
- 'check')
-source=(http://www.tbi.univie.ac.at/RNA/packages/source/mlapack-${pkgver}.tar.gz)
+ 'libtool')
-#create this sum with the command "sha256sum mpack-${pkgver}.tar.gz" before each build of the package
-sha256sums=('7f2e40ff9b656583b75591892e86e7eb2bdc9a593438a2e66e663c4ef7fde509')
+checkdepends=('check')
+
+source=(https://github.com/RaumZeit/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+
+sha256sums=('a0810b16b85f442f90933f04a5e4a4e8fb3ec234d755e1ed5ef72dcf04d4709a')
build() {
cd "${srcdir}/mlapack-${pkgver}"
- ./configure --prefix=/usr --enable-gmp --enable-mpfr --enable-qd --enable-dd --enable-double --enable-__float128 --enable-longdouble --enable-optimization --with-system-gmp --with-system-mpfr --with-system-mpc --with-system-qd --disable-benchmark --disable-examples --disable-reference
+ ./configure \
+ --prefix=/usr \
+ --enable-gmp \
+ --enable-mpfr \
+ --enable-qd \
+ --enable-dd \
+ --enable-double \
+ --enable-__float128 \
+ --enable-longdouble \
+ --enable-optimization \
+ --with-system-gmp \
+ --with-system-mpfr \
+ --with-system-mpc \
+ --with-system-qd \
+ --disable-benchmark \
+ --disable-examples \
+ --disable-reference
make
}
check() {
- cd "$srcdir/mlapack-${pkgver}"
+ cd "$srcdir/${pkgname}-${pkgver}"
make check
}
-package_mlapack() {
+package() {
depends=('qd'
'gmp'
'mpfr'
@@ -42,14 +59,13 @@ package_mlapack() {
# install library and header files
- cd "${srcdir}/mlapack-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
# install pkg-config file
install -Dm644 mlapack.pc "$pkgdir/usr/lib/pkgconfig/mlapack.pc"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- cd ../..
}