summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5559d37ecac3..4151a3308079 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
pkgdesc='Flexible terminal-based text editor'
pkgname=mle
-pkgver=1.3
-pkgrel=2
+pkgver=1.7.2
+pkgrel=1
url='https://github.com/adsr/mle'
license=(Apache)
arch=(x86_64)
-depends=(pcre termbox lua)
+conflicts=(mle-git)
+depends=(pcre2 lua)
makedepends=(uthash)
source=("${url}/archive/v${pkgver}.tar.gz")
-sha512sums=('52a7d1ed231b340fc0141d55068823dcf74aae800362afcb86b4f98d01f5b17b7872b38756b989b892bac84290744555049e5f4fd46424539a7b6aa7dedfc2f8')
+b2sums=('a1a29e97245e5604608039b25f8f5c2e9bb27939f795d52d61fa57e679731c06680e75b0fe0dbe80dca511899422d757da0ba73023e2ecf8d937455fa621a78a')
prepare () {
- cd "${pkgname}-${pkgver}"
-
- # The source code uses <lua5.3/lua.h>; and the Arch Linux "lua" package
- # places the headers directly under /usr/include, so let's just use a
- # symlink to provide the headers at the expected include location.
- ln -snf /usr/include lua5.3
+ # The Arch Linux Lua package does not have an include/lua5.4 subdir,
+ # per-version subdirs are only available for the older releases; but
+ # mle.h wants to use lua5.4/lua*.h nevertheless.
+ ln -snf /usr/include "${pkgname}-${pkgver}/lua5.4"
}
build () {