summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca84068664de..0a79049706d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,14 @@
# Maintainer: Adrián Pérez de Castro
pkgdesc='Flexible terminal-based text editor'
pkgname=mle-git
-pkgver=r365.157724d
+pkgver=r379.af76670
pkgrel=1
arch=(x86_64)
url='https://github.com/adsr/mle'
-depends=(pcre2)
-source=("${pkgname}::git+${url}"
- git+https://github.com/lua/lua
- git+https://github.com/adsr/mlbuf
- git+https://github.com/nsf/termbox
- git+https://github.com/troydhanson/uthash
-)
-sha512sums=(SKIP SKIP SKIP SKIP SKIP)
+depends=(pcre termbox lua)
+makedepends=(git uthash)
+source=("${pkgname}::git+${url}")
+sha512sums=(SKIP)
pkgver () {
cd "${pkgname}"
@@ -25,12 +21,11 @@ pkgver () {
prepare () {
cd "${pkgname}"
- git submodule init
- local m
- for m in mlbuf termbox uthash ; do
- git config "submodule.${m}.url" "${srcdir}/${m}"
- done
- git submodule update
+
+ # The source code uses <lua5.3/lua.h>; and the Arch Linux "lua" package
+ # places the headers directly under /usr/include, so let's just use a
+ # symlink to provide the headers at the expected include location.
+ ln -snf /usr/include lua5.3
}
build () {