summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d6fb43651f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Luis PĂ©rez <luis.perez@protonmail.com>
+pkgname=mmark
+pkgver=2.2.9
+pkgrel=1
+pkgdesc='A powerful markdown processor in Go geared towards the IETF'
+arch=('x86_64')
+url="https://github.com/mmarkdown/mmark"
+license=('BSD')
+makedepends=(
+ 'go'
+ 'git'
+)
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('70f080363ab3590e02471a7a48d6efc976072374dcbccd09884667f2002993fb')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}