summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f8d20064892..3e38a4c38bc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=mmc-utils
pkgname=${_pkgname}-git
-pkgver=r98.d7b343f
+pkgver=r109.145c74a
pkgrel=1
epoch=1
pkgdesc="Userspace tools for MMC/SD devices"
@@ -13,16 +13,28 @@ license=('GPL')
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=('git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
-sha256sums=('SKIP')
+source=(
+ 'git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git'
+ 'append-CFLAGS.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc'
+)
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${_pkgname}"
+ patch --forward --strip=1 --input="${srcdir}/append-CFLAGS.patch"
+}
+
build() {
- make -C "${_pkgname}"
+ cd "${_pkgname}"
+ make
}
package() {