summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68cc9b005020..dd2a7a3e235f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname='moc-pulse'
_pkgname='moc'
pkgver=2.5.2
-pkgrel=10
+pkgrel=12
pkgdesc='An ncurses console audio player with support for pulseaudio'
arch=('x86_64')
url="https://moc.daper.net/"
license=('GPL')
-depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'sndio' 'pulseaudio')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'sndio')
makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
optdepends=('speex: for using the speex plugin'
'ffmpeg4.4: for using the ffmpeg plugin'
@@ -18,19 +18,18 @@ optdepends=('speex: for using the speex plugin'
'libmpcdec: for using the musepack plugin'
'wavpack: for using the wavpack plugin'
'faad2: for using the aac plugin'
- 'libmodplug: for using the modplug plugin')
+ 'libmodplug: for using the modplug plugin'
+ 'pulseaudio: for using the pulseaudio plugin')
provides=('moc')
conflicts=('moc')
source=("https://ftp.daper.net/pub/soft/${_pkgname}/stable/${_pkgname}-${pkgver}.tar.bz2"
'pulseaudio.patch'
'moc-ffmpeg4.patch'
- 'moc-https.patch'
- '0001-Workaround-mbsrtowcs-fortify-crash-in-GLIBC-2.35.patch')
+ 'moc-https.patch')
sha1sums=('9d27a929b63099416263471c16367997c0ae6dba'
'5c6385760ba40ee8a330d28d520c44eac2cbbae1'
'007a0580ac754e1c318a0d0b6f0d403883797eaf'
- 'e3362ddd41126e2be874cd372a053fdaccf0f616'
- 'd3673707b2d96c34287042dc26698b2c5a00952a')
+ 'e3362ddd41126e2be874cd372a053fdaccf0f616')
# validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
prepare() {
@@ -43,9 +42,6 @@ prepare() {
# Add pulseaudio backend
patch -p1 -i ../pulseaudio.patch
- # HOTFIX for GLIBC 2.35 buffer overflow error
- patch -p1 -i ../0001-Workaround-mbsrtowcs-fortify-crash-in-GLIBC-2.35.patch
-
# reconfigure the build system
autoreconf -i -f
}