summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb789bda3b00..7d2e384018cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
-#Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+#Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
#Contributor: Øyvind 'MrElendig' Heggstad <mrelendig@har-ikkje.net>
#Contributor: jsteel <mail at jsteel dot org>
_pkgname=moc
pkgname="${_pkgname}-pulse-svn"
-pkgver=r2963
-pkgrel=1
+pkgver=r3005
+pkgrel=3
pkgdesc='An ncurses console audio player with support for pulseaudio (SVN)'
url='http://moc.daper.net'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'pulseaudio')
-makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack'
- 'libmodplug' 'subversion' 'faad2' 'pulseaudio')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'sndio')
+makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2' 'subversion')
optdepends=('speex: for using the speex plugin'
- 'ffmpeg: for using the ffmpeg plugin'
+ 'ffmpeg4.4: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
'libmpcdec: for using the musepack plugin'
'wavpack: for using the wavpack plugin'
'libmodplug: for using the modplug plugin'
- 'faad2: for use the aac plugin')
+ 'faad2: for use the aac plugin'
+ 'pulseaudio: for using the pulseaudio plugin')
conflicts=('moc')
provides=('moc')
options=('!libtool')
source=("${pkgname}::svn://daper.net/moc/trunk"
'0001-Pulseaudio-backend.patch'
- 'moc-ffmpeg4.patch')
+ 'moc-https.patch')
sha1sums=('SKIP'
'd86a04606eaa0960f3b59626070cd231d37b6430'
- '007a0580ac754e1c318a0d0b6f0d403883797eaf')
+ 'e3362ddd41126e2be874cd372a053fdaccf0f616')
pkgver() {
cd "$srcdir/$pkgname"
@@ -38,18 +38,21 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
- # Fix build with ffmpeg 4 (taken from official release on ArchLinux)
- patch -p0 -i ../moc-ffmpeg4.patch
+ # Allow https for urls https://moc.daper.net/node/1872 (taken from official release on ArchLinux)
+ patch -p0 -i ../moc-https.patch
# Add pulseaudio backend
patch -p1 -i ../0001-Pulseaudio-backend.patch
# re-configure
- autoreconf -f -i -Wall,no-obsolete
+ autoreconf -i -f
}
build() {
cd "$srcdir/$pkgname"
+
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+
./configure --prefix=/usr --without-rcc --with-pulse \
--with-alsa --with-oss --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \
@@ -62,3 +65,5 @@ package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}
+
+# vim: ts=2 sw=2