summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c97b2b57db71..42ce70687c68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Eric Bélanger <eric@archlinux.org>
+# Maintainer: Hajós Attila <linux.alucard@gmail.com>
+# Contributor: Eric Bélanger <eric@archlinux.org>
pkgname=moc-unstable
_pkgname=moc
@@ -11,13 +12,13 @@ arch=('x86_64')
url="https://moc.daper.net/"
license=('GPL')
depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
-makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
+makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2')
optdepends=('speex: for using the speex plugin'
- 'ffmpeg: for using the ffmpeg plugin'
+ 'ffmpeg4.4: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
'libmpcdec: for using the musepack plugin'
- 'wavpack: for using the wavpack plugin'
- 'faad2: for using the aac plugin'
+ 'wavpack: for using the wavpack plugin'
+ 'faad2: for using the aac plugin'
'libmodplug: for using the modplug plugin')
source=(http://ftp.daper.net/pub/soft/moc/unstable/${_pkgname}-${_pkgver}.tar.{xz,asc}
moc-ffmpeg4.patch
@@ -25,8 +26,8 @@ source=(http://ftp.daper.net/pub/soft/moc/unstable/${_pkgname}-${_pkgver}.tar.{x
conflicts=(moc)
provides=(moc)
sha1sums=('01400a96b6e40346c15ad02c38d494e10721fd63'
- 'SKIP'
'007a0580ac754e1c318a0d0b6f0d403883797eaf'
+ 'SKIP'
'e3362ddd41126e2be874cd372a053fdaccf0f616')
validpgpkeys=('59359B80406D9E73E80599BEF3121E4F2885A7AA')
@@ -38,6 +39,7 @@ prepare() {
build() {
cd ${_pkgname}-${_pkgver}
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
./configure --prefix=/usr --without-rcc \
--with-oss --with-alsa --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \