summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0953494b0a5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: alzeih <alzeih@users.noreply.github.com>
+pkgname=mod_auth_openidc
+pkgver=2.4.3
+pkgrel=1
+pkgdesc="An authentication/authorization module for the Apache 2.x HTTP server that functions as an OpenID Connect Relying Party, authenticating users against an OpenID Connect Provider."
+arch=('x86_64')
+url="https://www.mod-auth-openidc.org/"
+license=('Apache')
+depends=('curl' 'cjose' 'pcre')
+makedepends=('apache' 'jansson' 'cjose')
+source=("https://github.com/zmartzone/mod_auth_openidc/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha512sums=('c4fa4f99f2005cab230f4b8a3dd70cc99c281fc4ff679472f0c1a5920372b53ce2b5e34a8f87e14fc92055d3b9c75dd58f77f539f69571a1af0db10bdc6ea1ab')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ APXS2_OPTS="-S LIBEXECDIR=$pkgdir/usr/lib/httpd/modules/" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -dm755 "$pkgdir/usr/lib/httpd/modules"
+ make install
+}
+