summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2158071b687e..4b8b51eb2945 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: dncrash <dncrash at gmail dot com>
pkgname="molecule"
-pkgver=3.0a4
+pkgver=3.0a5
pkgrel=1
pkgdesc='aids in the development and testing of Ansible roles.'
-url='https://github.com/metacloud/molecule'
+url='https://github.com/ansible/molecule'
arch=('any')
license=('MIT')
makedepends=('python' 'python-setuptools' 'python-cerberus' 'python-testinfra')
-depends=('ansible-lint'
+depends=('ansible'
+ 'ansible-lint'
'python-anyconfig'
'python-cerberus'
'python-click'
@@ -18,25 +19,27 @@ depends=('ansible-lint'
'flake8'
'python-gilt'
'python-jinja'
- 'python-pbr'
+ 'python-paramiko'
+ 'python-pathlib2'
'python-pexpect'
- 'python-psutil'
+ 'python-pluggy'
+ 'python-pre-commmit'
'python-pyaml'
'python-sh'
'python-six'
+ 'python-subprocess2'
'python-tabulate'
'python-testinfra'
'python-tree-format-git'
- 'yamllint'
- 'python-shellingham')
+ 'yamllint')
checkdepends=('python' 'python-tox')
optdepends=('python-docker: docker driver'
'python-boto: EC2 driver'
'python-vagrant: vagrant driver'
'python-shade: openstack driver')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/metacloud/molecule/archive/${pkgver}.tar.gz")
-sha256sums=('7b81fcb7816639426c619d10b2a768913f7d5152340df7fb2277ef84482551e6')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ansible/molecule/archive/${pkgver}.tar.gz")
+sha256sums=('a78050a00f51d806215e5cc5420dcb5c1403340fd25155b42f3b26d7cd10d97d')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"