summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bea81a3e754..b412d4e72e01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Morten Linderud <morten@linderud.pw>
pkgname="molecule"
pkgver=2.0.4
-pkgrel=1
+pkgrel=2
_commit=303337927095ab09957fca03ad145f176d0acb0c
pkgdesc='aids in the development and testing of Ansible roles.'
url='https://github.com/metacloud/molecule/tree/2.0.0.rc12'
@@ -13,6 +13,7 @@ depends=('ansible-lint' 'python-ansible' 'python-colorama' 'flake8'
'python-tabulate' 'python-pbr' 'python-pexpect' 'python-cookiecutter'
'python-yaml' 'python-sh' 'python-click' 'python-click-completion'
'python-tree-format-git' 'yamllint' 'python-anyconfig')
+checkdepends=('python' 'python-tox')
optdepends=('python-docker: docker driver'
'python-boto: EC2 driver'
'python-vagrant: vagrant driver'
@@ -26,6 +27,11 @@ build() {
python setup.py build
}
+check(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ tox -e py2,py3
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
export PBR_VERSION="${pkgver}"