summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe1dcb37f70c..19d42ade341c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: gardar <aur@gardar.net>
pkgname=molecule-containers
-pkgver=1.0.2
-pkgrel=4
+pkgver=2.0.0
+pkgrel=1
pkgdesc="Molecule Container-agnostic Driver Plugin"
arch=('any')
url="https://github.com/ansible-community/molecule-containers"
license=('MIT')
depends=('molecule' 'python-ansible-compat' 'python-selinux')
-makedepends=('python-setuptools-scm' 'python-setuptools-scm-git-archive' 'python-build' 'python-install')
+makedepends=('python-setuptools-scm' 'python-setuptools-scm-git-archive' 'python-build' 'python-installer')
checkdepends=('python-pytest' 'python-pytest-cov')
optdepends=('podman: for using a local podman setup' 'docker: for using a local docker setup')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('ad2bfb61e3c0608e981ce9a8f466e21cb5c62e0310f1cc13fd3555ff5b53e11cba0263756b6fd8ea70cc1cf1bbd259bd577e8d4fdb4e27f1461f79baf684e270')
-b2sums=('3b88f6c4a12ddad8fd993cbffed23f1cc941a696fceb24ef309c4bc6ede36debc6bcfd0c09807fefdaf15e4fcc70bf925f8caaf4ec806c146e5de98afd27f54c')
+sha512sums=('596fc31ea49ec541f44b5ea6cdd8c48a0e05192b8ab5b412ebbca0a6eb1ae8008c9ac9173e5ec5c40561c2a462122f28c5e95b848cbf2eb18649bf379b309c83')
+b2sums=('d428757f3532709462d33feca2e23c2f066a0297ce980ae5012aa841c1ef624f4d31faa8f7038542f029af1ac3e9832e40b6290dad96859c08770515efd04a8c')
build() {
cd "$pkgname-$pkgver"
@@ -30,7 +30,7 @@ check() {
package() {
cd "$pkgname-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="${pkgdir}" --compile-bytecode=1 dist/*.whl
install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -vDm 644 README.rst \
-t "${pkgdir}/usr/share/doc/${pkgname}"