summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a48506eff6cf..160f80dc19e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=molotov
-pkgver=4.4.0
+# Check last version by a call on https://desktop-auto-upgrade.molotov.tv/linux/manifest.json
+pkgver=4.4.4
pkgrel=1
pkgdesc="Streaming access to French (only) TV channels."
arch=('i686' 'x86_64')
@@ -12,7 +13,7 @@ makedepends=('p7zip')
options=('!strip')
source=("Molotov-${pkgver}.AppImage::http://desktop-auto-upgrade.molotov.tv/linux/${pkgver}/$pkgname.AppImage"
'molotov')
-sha256sums=('978225ea2f2e5d2789a87dc84c2f195292973d06f4a9c5bb4a92b1d51e3a5c37'
+sha256sums=('bd2b9cdc4ecfb4b101e0861644e41fee436a37a1a3a505d4646dcf57610b4ad8'
'3a2d0c45ec2a964b229ee44a729d5d86319d573296ca44c8a33e171ce23a3b47')
prepare() {
@@ -23,9 +24,8 @@ prepare() {
build() {
cd $srcdir
- sed -i "s/^Exec=AppRun %U$/Exec=$pkgname/" squashfs-root/@molotovdesktop-wrapper.desktop
- sed -i "s/^Icon=@molotovdesktop-wrapper$/Icon=$pkgname/" squashfs-root/@molotovdesktop-wrapper.desktop
- sed -i "s/^Categories=AudioVideo/Categories=Video;Player;AudioVideo/" squashfs-root/@molotovdesktop-wrapper.desktop
+ sed -i "s/^Exec=AppRun --no-sandbox %U$/Exec=$pkgname/" squashfs-root/molotov.desktop
+ sed -i "s/^Categories=AudioVideo/Categories=Video;Player;AudioVideo/" squashfs-root/molotov.desktop
sed -i "s/MOLOTOV_VERSION/${pkgver}/g" molotov
}
@@ -40,10 +40,10 @@ package() {
hicolor="squashfs-root/usr/share/icons/hicolor"
for size in $(ls -1 $hicolor); do
install -d -m755 $pkgdir/usr/share/icons/hicolor/$size/apps
- install -D -m644 $hicolor/$size/apps/@molotovdesktop-wrapper.png $pkgdir/usr/share/icons/hicolor/$size/apps/molotov.png
+ install -D -m644 $hicolor/$size/apps/molotov.png $pkgdir/usr/share/icons/hicolor/$size/apps/molotov.png
done
- install -D -m644 squashfs-root/@molotovdesktop-wrapper.desktop $pkgdir/usr/share/applications/appimagekit-molotov.desktop
+ install -D -m644 squashfs-root/molotov.desktop $pkgdir/usr/share/applications/appimagekit-molotov.desktop
install -D -m755 molotov $pkgdir/usr/bin/molotov
install -D -m755 Molotov-$pkgver.AppImage $pkgdir/opt/appimages/Molotov-$pkgver.AppImage
rm -r squashfs-root