summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6e164cf8825..2ddcda9ca150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joshua Hardy joshinsilico
pkgname=molprobity-git
pkgver=r1013.ee5bdd4
-pkgrel=1
+pkgrel=2
pkgdesc="All-atom structure validation for macromolecular crystallography"
arch=('any')
url="http://molprobity.biochem.duke.edu/"
@@ -11,8 +11,9 @@ makedepends=('python2' 'git' 'subversion' 'curl' 'tar' 'make' 'gawk')
provides=("${pkgname%-VCS}")
conflicts=("${pkgname%-VCS}")
options=('!strip')
-source=('molprobity-git::git+https://github.com/rlabduke/MolProbity#branch=molprobity_4.2')
-md5sums=('SKIP')
+source=('molprobity-git::git+https://github.com/rlabduke/MolProbity#branch=molprobity_4.2'
+'molprobity.sh')
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-VCS}"
@@ -32,7 +33,8 @@ build() {
package() {
cd "$srcdir/${pkgname%-VCS}"
- install -d "${pkgdir}"/opt/MolProbity "${pkgdir}"/usr/share/licenses/molprobity-git
+ install -d "${pkgdir}"/opt/MolProbity "${pkgdir}"/usr/share/licenses/molprobity-git $pkgdir/etc/profile.d/
cp -r * "${pkgdir}"/opt/MolProbity/.
cp LICENSE.html "${pkgdir}"/usr/share/licenses/molprobity-git/.
+ cp $srcdir/molprobity.sh $pkgdir/etc/profile.d/.
}