summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fada4c2e14f..d0c6a63819b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: TDY <tdy@gmx.com>
pkgname=moneymanagerex-git
-pkgver=1.5.13
+pkgver=1.5.14
pkgrel=1
pkgdesc="MoneyManagerEx is an easy-to-use personal finance suite. This package will always point to the newest tagged version."
arch=('x86_64')
url="http://www.moneymanagerex.org/"
license=('GPL')
-depends=('wxgtk3-dev' 'webkit2gtk')
+depends=('wxgtk3-dev-opt' 'webkit2gtk')
makedepends=('curl' 'cmake' 'fakeroot' 'file' 'gawk' 'gcc' 'gettext' 'git' 'jq' 'lsb-release' 'make' 'pkg-config' 'rapidjson')
optdepends=('cups: for printing support')
replaces=('mmex')
@@ -34,7 +34,12 @@ prepare() {
build() {
cd "${srcdir}"/moneymanagerex
- cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 .
+ # Disable all warnings when building, then configure CMake
+ export CXXFLAGS=-w
+ cmake -DCMAKE_BUILD_TYPE=Release -DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev/bin/wx-config-gtk3 .
+
+ # Make sure the linker bakes the non-standard path for wxWidgets into the executable
+ export LD_RUN_PATH=/opt/wxgtk-dev/lib
cmake --build . --target package
}