summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e566b90455d2..fe061b5ead45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,9 +16,14 @@ optdepends=('cups: for printing support')
replaces=('mmex')
provides=('moneymanagerex')
conflicts=('moneymanagerex')
-source=(git+https://github.com/moneymanagerex/moneymanagerex.git#tag=v$pkgver)
+source=(git+https://github.com/moneymanagerex/moneymanagerex.git)
sha256sums=('SKIP')
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --abbrev=0 | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${pkgname%-git}"
mkdir -p build