summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37ccd40909d6..7519e5e198bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,12 @@ _pkgver='1.38.0-beta.4'
pkgver="$(printf '%s' "$_pkgver" | tr '-' '.')"
pkgrel='1'
pkgdesc='The official GUI for MongoDB - beta version'
-# If you're running on armv7h or aarch64, use the electron22-bin package from the AUR for the electron dependency
-# If you're running on armv7h, you have to add it to the arch and source arrays of the electron22-bin AUR dependency
+# If you're running on armv7h or aarch64, use the electron23-bin package from the AUR for the electron dependency
+# If you're running on armv7h, you have to add it to the arch and source arrays of the electron23-bin AUR dependency
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.mongodb.com/products/compass'
license=('custom:SSPL')
-if [[ "$_target" =~ -beta$ ]]; then
- _electronpkg='electron23'
-else
- _electronpkg='electron22'
-fi
-
+_electronpkg='electron23'
depends=("$_electronpkg" 'krb5' 'libsecret' 'lsb-release')
makedepends=('git' 'nodejs>=16.15.1' 'npm>=8.19.2' 'python' 'unzip')
optdepends=('org.freedesktop.secrets')