summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index faa4f37def67..febb536b29ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
pkgname=moonlight-qt
-pkgver=0.1.0
+pkgver=0.3.0
pkgrel=1
pkgdesc='GameStream client for PCs (Windows, Mac, and Linux)'
arch=('x86_64')
@@ -9,16 +9,20 @@ license=('GPL')
url='https://moonlight-stream.com'
depends=('qt5-base' 'qt5-quickcontrols' 'qt5-quickcontrols2')
optdepends=('libva-intel-driver: hardware acceleration for Intel GPUs')
-source=($pkgname::"git+https://github.com/moonlight-stream/${pkgname}.git#tag=v${pkgver}")
+source=($pkgname::"git+https://github.com/moonlight-stream/${pkgname}.git")
md5sums=('SKIP')
-prepare() {
+pkgver() {
cd "$pkgname"
- git submodule update --init --recursive
+ git describe --long --tags | sed 's/^v//;s/-.*//'
}
build() {
cd "$pkgname"
+
+ git checkout v${pkgver}
+ git submodule update --init --recursive
+
qmake PREFIX="$pkgdir/usr"
make
}